Cisco router configuration for O2 broadband connections

I’ve been asked to provide a basic config for a Cisco router (800 series) for use with an O2 broadband account. Initially these accounts were supplied using PPPoE, however, they are now supplied as PPPoA. I’ll just be providing the ATM interface setup and the Dialer interface, the rest is up to you! These configurations (especially the PPPoA) are good for nearly all UK broadband offerings and most Cisco DSL routers. Take a look at my previous post for Cisco FTTC router setup

PPPoA Setup

interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 dsl operating-mode auto 

interface Dialer0
 ip address negotiated
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname _your_username_
 ppp chap password _your_password_

ip route 0.0.0.0 0.0.0.0 Dialer0

PPPoE Setup

interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl sync mode itu previous
 dsl operating-mode auto
 dsl enable-training-log delay 5  

interface ATM0.1 point-to-point
 ip mtu 1500
 pvc 0/101
  encapsulation aal5snap
  pppoe-client dial-pool-number 1

interface Dialer0
 mtu 1492
 ip address negotiated
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 ppp chap hostname _your_username_
 ppp chap password _your_password_

ip route 0.0.0.0 0.0.0.0 Dialer0

I hope thats of some help.
<shameless plug>I should also say that Gconnect provide Cisco Consultancy Services, either as ‘ad-hoc’ or ongoing support contracts. </shameless plug>

This entry was posted in Cisco. Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *