BT FTTC (Infinity) Cisco Router Configuration

With FTTC spreading out across the UK like a very slow moving thing, its time to brush up on the PPPoE setup on our Cisco routers. BT Wholesale provide a fairly nasty VDSL modem as part of the installation for FTTC, so all we need is an ethernet presented router to connect up. Up to now we have been using the trusty old Draytek 2830 as they ‘just work’, however , the customers need something fancier with more ‘stuff’ or features. My test here is on a Cisco 861 which has 5 ethernet ports, 1 assign as a WAN port and a 4 port switch. Ive read a lot about how the Cisco 800 routers lack the resources to run data a 40Mbits/sec, and you can check it out yourself on the following pdf:

Cisco router performance chart

So down the configuration. I’m using FastEthernet4 as my ‘WAN’ link and here is the sanitised version:

vpdn enable
!
vpdn-group 1
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description *** FTTC ***
no ip address
duplex auto
speed auto
pppoe-client dial-pool-number 1
!
interface Dialer0
mtu 1492
ip address negotiated
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname XXXXXXXXXXXXX
ppp chap password 0 XXXXXXXXXXXXX
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
dialer-list 1 protocol ip permit
!

Test and working – I also set it up as a NAT router for testing.

This entry was posted in Cisco and tagged , , . Bookmark the permalink.

Leave a Reply